マイクロソフトエッジでの不信サイト表示について < 不具合報告

不具合報告では、その現象が確認できるURLを添えて、ご報告ください。
(+できれば画像も添付していただければ助かります。)

トピックを立てる前にチェックしてね!
  1. 初めてご利用の方は、 「フォーラムガイドライン」・「よくある質問」・「SWELLでの非推奨プラグイン」に一度は目を通しておいてください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. WordPressでの不具合が全てテーマによる不具合だとは限りません
    本当にテーマによる問題かどうか、プラグインを見直して解決しないかどうかも先に検証しておいていただけると、非常に助かります。
  4. まずはGoogleで検索してみて、自力で解決できる問題かどうかを調べてみてください。
    ここで質問しようとしている内容をそのまま検索すれば答えが見つかるかもしれません。
マイクロソフトエッジでの不信サイト表示...
 
通知
すべてクリア

[解決済] マイクロソフトエッジでの不信サイト表示について

kukuri1245
(@kukuri1245)
Active Member

過去にトピックとしてあがっていないようなので、追加させていただきます。

ブログがクロムでは問題なく表示されているのですが、マイクロソフトエッジで表示させると添付のように不信なサイトとしてエラーがでています。リンク先を見るとテーマディレクトリの中にあるpng保存先がなりすましサイトとしてエラーが出ているようです。解決方法をご教示いただけないでしょうか。

トップページと9月以降に作成した記事ではこのエラーは発生しません。

お忙しいところ恐縮ですがどうぞよろしくお願いします。

引用
Topic starter 投稿済 : 30/12/2020 10:10 am
しらこ
(@96ssbike)
Estimable Member

現状、iframeを使用しているとEdgeでこのような現象が出ることがあるのが確認されています。

具体的には、Amazonアソシエイトの埋め込みがその判定対象になるみたいなのですが、外していただけるととりあえずは対処可能です。

では、外した後はどのようにするか?なのですが、代替方法としては、Amazon側で画像の埋め込みタグを発行する、たとえばSWELLの広告タグで広告を作成する、などです。

根本解決ではありませんが、取り急ぎ代わりの方法をシェアしておきます。

返信引用
投稿済 : 30/12/2020 12:42 pm
kukuri1245 件のいいね!
しらこ
(@96ssbike)
Estimable Member

ちなみに、この現象が必ず出るわけではなくて、過去に何人かのサイトオーナーさんがこの現象が確認されています。私は、出たことがないのですが…💦

返信引用
投稿済 : 30/12/2020 12:47 pm
kukuri1245
(@kukuri1245)
Active Member

@96ssbike さま

お返事ありがとうございます。

とりいそぎTwitterの埋め込みとYouTubeの埋め込みとAmazonの埋め込みを記事から削除したところ、問い合わせさせていただいた事象は消えました。

埋込たい動画等がある場合に、方法を検討する必要がありそうです。

まずはお礼まで。

ありがとうございます、助かりました。

返信引用
Topic starter 投稿済 : 30/12/2020 1:20 pm
しらこ 件のいいね!
了
 
(@ryo)
メンバー Admin

以前は.pngじゃなくて.gifだったのですが以前同様の報告があり、gifがダメなのかと試しにpngに変えていたのですが、それだけじゃやはり根本的な解決にならないのですね... 🤔 

「placeholder.png」は、画像のLazyloadの際にimgタグに予めいれておくためのものなのですが、EdgeとLazyloadの相性が悪いというような記事もちらほら見かけました...。

試しに、placeholderを使わない形に変えてみようかと思います。

返信引用
投稿済 : 30/12/2020 1:49 pm
kukuri1245 件のいいね!
了
 
(@ryo)
メンバー Admin

あ...!すみません、原因分かったかもです。

「iframeを使用していると~」というところを改めて考えてみるとヒントになりました、しらこさんありがとうございます!

返信引用
投稿済 : 30/12/2020 1:56 pm
しらこkukuri1245 件のいいね!
kukuri1245
(@kukuri1245)
Active Member

@ryo さま

早速のお返事ありがとうございます。

原因がおわかりになられたとのこと、ありがとうございます。

ひきつづきどうぞよろしくお願いします。

返信引用
Topic starter 投稿済 : 30/12/2020 2:04 pm
了
 
(@ryo)
メンバー Admin

ver.2.2.9.1にて修正してみました...!いかがでしょうか?

返信引用
投稿済 : 30/12/2020 4:02 pm
しらこkukuri1245 件のいいね!
kukuri1245
(@kukuri1245)
Active Member

@ryoさま

早いです!確認してみます、ありがとうございます。

取り急ぎお礼まで。

返信引用
Topic starter 投稿済 : 30/12/2020 6:06 pm
しらこ
(@96ssbike)
Estimable Member

@kukuri1245 さん、ちなみに記事のリビジョン機能を使っていただければ、簡単に元の記事に戻すことができます… 👍 

返信引用
投稿済 : 30/12/2020 6:13 pm
kukuri1245 件のいいね!
kukuri1245
(@kukuri1245)
Active Member

@ryoさま

ありがとうございます、Amazonのiframeを記事中に挿入しましたが、ご報告さしあげたエラーは出なくなりました。迅速なご対応ありがとうございます。

ひきつづきよろしくおねがいいたします。

返信引用
Topic starter 投稿済 : 30/12/2020 6:16 pm
しらこ
(@96ssbike)
Estimable Member

今拝見したら、Amazonのリンクと、YouTubeと埋め込み大丈夫っぽいですね。

念のため、当方でサイトを訪問し、該当ページを見て動作確認させていただきました。

(できれば、確認してみます!だけではなくて、その結果もフィードバックしていただけると、開発者さん・他のみんなにも役立ちますので、ご協力をお願いします)

返信引用
投稿済 : 02/01/2021 7:18 pm
しらこ
(@96ssbike)
Estimable Member

(ちなみに、/wp-content/themes/swell/style.css も直接見に行って、最新verのテーマをご使用の旨も確認させていただきました)

返信引用
投稿済 : 02/01/2021 7:23 pm
kukuri1245
(@kukuri1245)
Active Member

@96ssbike しらこさま

「ありがとうございます、Amazonのiframeを記事中に挿入しましたが、ご報告さしあげたエラーは出なくなりました。迅速なご対応ありがとうございます。ひきつづきよろしくおねがいいたします。」とお返事を30日中に書かせていただいたのですが、承認待ちとなってしまっておりました。

無事に反映できております、ご確認いただきましてありがとうございました。

返信引用
Topic starter 投稿済 : 02/01/2021 10:30 pm
kukuri1245
(@kukuri1245)
Active Member

しらこさま

「ありがとうございます、Amazonのiframeを記事中に挿入しましたが、ご報告さしあげたエラーは出なくなりました。迅速なご対応ありがとうございます。ひきつづきよろしくおねがいいたします。」とお返事を30日中に書かせていただいたのですが、承認待ちとなってしまっておりました。

無事に反映できております、ご確認いただきましてありがとうございました。

返信引用
Topic starter 投稿済 : 02/01/2021 10:34 pm
しらこ 件のいいね!
しらこ
(@96ssbike)
Estimable Member

そうだったのですね…💦失礼しました。解決したとのこと、おめでとうございます。

また、了さん解決していただきありがとうございました。念のため、以前同じ現象が出た方にもSlackからお伝えしてみました。

返信引用
投稿済 : 03/01/2021 9:53 pm
共有: