【2.3.0.3】吹き出しの設定内容が記事に反映されない件 < 不具合報告

不具合報告では、その現象が確認できるURLを添えて、ご報告ください。
(+できれば画像も添付していただければ助かります。)

トピックを立てる前にチェックしてね!
  1. 初めてご利用の方は、 「フォーラムガイドライン」・「よくある質問」・「SWELLでの非推奨プラグイン」に一度は目を通しておいてください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. WordPressでの不具合が全てテーマによる不具合だとは限りません
    本当にテーマによる問題かどうか、プラグインを見直して解決しないかどうかも先に検証しておいていただけると、非常に助かります。
  4. まずはGoogleで検索してみて、自力で解決できる問題かどうかを調べてみてください。
    ここで質問しようとしている内容をそのまま検索すれば答えが見つかるかもしれません。
【2.3.0.3】吹き出しの設定内容が...
 
通知
すべてクリア

【2.3.0.3】吹き出しの設定内容が記事に反映されない件

ちゃみ
(@charmy)
Active Member

お世話になります。

Twitterでやり取りさせていただいた、吹き出しの表示の件です。

SWELL バージョン: 2.3.0.3

SWELLのバージョンアップに伴い、メニューの吹き出し設定がデフォルトに戻ってしまいました。

更新しようと[更新]ボタンを押しても設定が反映されません。

吹き出しを入れた新規記事も、デフォルトの吹き出しで表示されてしまっています。

https://ouchi-iku.com/diy-toy/

画像を添付いたします。

以上、よろしくお願いいたします。

引用
Topic starter 投稿済 : 11/01/2021 5:12 pm
了
 
(@ryo)
メンバー Admin

この件、僕の環境では再現できずでして、GoogleChromeなどで画面を右クリックし、「検証」からコンソールになにかエラーが出ていないかなどもチェックしていただけると助かります...!

返信引用
投稿済 : 11/01/2021 5:20 pm
ちゃみ
(@charmy)
Active Member

@ryo ありがとうございます。コンソールエラー確認しましたが、出ていませんでした。

他にもいろいろ見てみます><

返信引用
Topic starter 投稿済 : 11/01/2021 5:58 pm
了
 
(@ryo)
メンバー Admin

ブラウザを変えたりするとどうでしょう?

返信引用
投稿済 : 11/01/2021 7:26 pm
ちゃみ 件のいいね!
ちゃみ
(@charmy)
Active Member

@ryo FireFox・Edgeで試しましたが、

✔エラーなし

✔メニューの吹き出し設定も設定が反映されない

状態です><

返信引用
Topic starter 投稿済 : 11/01/2021 7:39 pm
了
 
(@ryo)
メンバー Admin

じゃあプラグインの影響かもしれないですね...。

キャッシュ系のプラグインは結構怪しいです...!

返信引用
投稿済 : 11/01/2021 7:41 pm
ちゃみ 件のいいね!
しらこ
(@96ssbike)
Estimable Member

WAFの影響はないでしょうか…?

返信引用
投稿済 : 11/01/2021 8:34 pm
ちゃみ 件のいいね!
ちゃみ
(@charmy)
Active Member

@96ssbike しらこさん、こんばんは。ありがとうございます。

WAFの設定はすべてOFFになっていました(逆にやばい)。

プラグインをひとつずつ見てみます><

返信引用
Topic starter 投稿済 : 11/01/2021 8:46 pm
ちゃみ
(@charmy)
Active Member

@ryo 

プラグイン全停止

再ログイン

など試しましたが、ダメでした。

こちらの環境のせいは濃厚なんですが……><

返信引用
Topic starter 投稿済 : 11/01/2021 9:14 pm
了
 
(@ryo)
メンバー Admin

これ、新しくふきだしセット作ってもダメですか??

返信引用
投稿済 : 11/01/2021 9:25 pm
了
 
(@ryo)
メンバー Admin

あと、WordPressは最新ですかね?

返信引用
投稿済 : 11/01/2021 9:25 pm
ちゃみ
(@charmy)
Active Member

@ryo

はい、

✔ワードプレスは最新(ver. 5.6)

✔新しく吹き出しを作ってもダメです。

テストで作った吹き出し画像添付いたします。

色々設定しても、[更新]でデフォルトに戻ります。

返信引用
Topic starter 投稿済 : 11/01/2021 9:29 pm
了
 
(@ryo)
メンバー Admin

んー、なぜでしょう…💦

そういえば、ラジオボックスとかがグレーなのも少し気になりますね…普通は青色系になっている気が…

これ、ブラウザはなに使ってます?

返信引用
投稿済 : 11/01/2021 10:05 pm
ちゃみ
(@charmy)
Active Member

@ryo あ、グレーアウトしているのは、管理画面の配色を変えているからです!

※サンライズという配色にするとグレーになります。紛らわしくてすみません汗。

ブラウザはChrome、最新版です。

端末再起動かけてみます。

長々とお騒がせしています<m(__)m>

返信引用
Topic starter 投稿済 : 11/01/2021 10:27 pm
ちゃみ
(@charmy)
Active Member

@ryo

端末再起動でもダメでした。

ちょっと見えてきたんですが、

✔記事作成画面で新しく作った吹き出しは機能します。

✔管理画面メニューの吹き出しで作った吹き出しはデフォルトから変更できません。

といった現象の切り分けはできています。

返信引用
Topic starter 投稿済 : 11/01/2021 11:04 pm
ちゃみ
(@charmy)
Active Member

バージョンを2.2.9に戻しました。

が、管理画面メニューの吹き出しで作った吹き出しはデフォルトのまま変更できませんでした。

他機能に問題はなく、アップデートを契機に吹き出しだけがおかしくなったのが謎ですが、

吹き出しを再利用ブロックで作ることにします><

ありがとうございました<m(__)m>

This post was modified 2か月前 by ちゃみ
返信引用
Topic starter 投稿済 : 12/01/2021 12:35 am
しらこ 件のいいね!
しらこ
(@96ssbike)
Estimable Member

バージョンを旧バージョンに戻していただいたのは、さすがですね…!

できれば試して欲しかったのが、テーマの再インストール(再び最新バージョンに戻す)です。

テーマのstyle.cssに記述してあるバージョンを旧バージョンに書き換えるor旧バージョンをインストールする>最新バージョンにアップデートする、です。

旧バージョンに戻したところ、問題は引き続き継続するとのことでしたが、もしよろしければ…💦(ここまで来ると、これでは解決しないかもしれませんが、私が提示した作業で原因で大きな問題は引き起こさないと思いますので、念のため…💦)

This post was modified 2か月前 2回 by しらこ
返信引用
投稿済 : 12/01/2021 1:25 am
ちゃみ 件のいいね!
ちゃみ
(@charmy)
Active Member

@96ssbike 旧バージョンにしてもなおらなかったので、テーマは再び最新にしております。

やっぱりなおりません^^;

でも、コメントいただいて自分でやっていることが間違いではないと安心できました。

ありがとうございます!

返信引用
Topic starter 投稿済 : 12/01/2021 7:54 am
共有: